Jump to content
Sign in to follow this  
charliechalk

External Hard Drive doesn't work on laptop

Recommended Posts

So I bought one of those things and it worked fine on my pc and everythings cool everything is on there that should be on there.

Then I put it in my laptop and the laptop skitzed out and turns off every time I plug it in and run the programme.

I've got no viruses I do Spybot all the time and generally have no other problems with my laptop so what's the problem?

Thanks in advance.

Share this post


Link to post
Share on other sites
Guest Lens

start the laptop with the HD plugged in

eject the HD properly when You wana take it out. reason it's turning Your computer off is that it's drawing a voltage from the pc power supply, to power itself, when You eject it incorrectly, the pc suddenly gets more voltage than it's supposed to.

but while there's a topic and i don't need to make a new 1:

i use my HD in a pc. I wana use it in a Mac. it doesn't work in the Mac. what i do?

Share this post


Link to post
Share on other sites

Google the hard drive, see if there are any drivers you need to download (usually from the company website).

/

Lens do the same, but look to see if Mac Drivers are available.

Share this post


Link to post
Share on other sites
Guest FA23

but while there's a topic and i don't need to make a new 1:

i use my HD in a pc. I wana use it in a Mac. it doesn't work in the Mac. what i do?

you gotta format it to FAT32...

you wont be able to store any files over 4gb on it tho....

Share this post


Link to post
Share on other sites

somehow my external hd got a virus which avg immediately found and quarantined when I plugged it into my laptop. Only thing is now whenever I try and open the drive on my laptop it says access denied, works on any other pc/mac tho. I thought maybe it was avg that was blocking the access so disabled it but it still won't open the drive.

Share this post


Link to post
Share on other sites

Nah it doesn't turn off like that it bluescreens and says something about recently installed hardware.

Then it won't turn back on until I do system restore.

It doesn't come with drivers or a CD or nothing it automatically installs when ya plug it in well thats what it says and thats what it did on me pc.

Thanks for the help btw

Share this post


Link to post
Share on other sites
Guest Lens

right click the hard drive on the "my computer" screen, and select eject before You remove it

better still, remove the hard drive while the computer's off

Share this post


Link to post
Share on other sites

right click the hard drive on the "my computer" screen, and select eject before You remove it

better still, remove the hard drive while the computer's off

The computer turns itself off when the HD installs though so I don't even get a chance to remove it it just makes the laptop turn off

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×